JAMWiki
  1. JAMWiki
  2. JAMWIKI-92

File upload - Can't upload a file

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.2
    • Fix Version/s: None
    • Labels:
    • Environment:

      ubuntu server, glassfish 3.1.2

      Description

      When I try to upload a file I get the error (see screenshot):

      "Fehler
      Ein Systemfehler ist aufgetreten. Die Fehlermeldung lautet:
      Keine Datei zum Hochladen gefunden" (translation: no file found).

      I debugged it remotely:

      • The file paths and filesystem permissions seams to be allright.
      • The error is in the class "ServletUtil.java" (Line 576) in the Method "processMultipartRequest" in the codeline 'return (List<FileItem>)upload.parseRequest(request);'

      it returns an empty list. I'm not sure what the problem is. At stackoverflow are a lot of similar problems.

      It's very annoying because I really have no idea how to fix it, but have to run the software on a productive server.

      Greets, Pawel

        Activity

        Ryan Holliday
        added a comment -

        Are there any error messages in your logs, and if so can you attach any relevant stack trace to this bug report? Does the uploaded file have any non-ANSI characters in the name? Does this occur with all files, or can some be uploaded successfully? I've been busy with other things lately so haven't had a lot of time for JAMWiki development, but it's a long weekend here in the US so hopefully I'll be able to investigate in the next couple of days.

        Show
        Ryan Holliday
        added a comment - Are there any error messages in your logs, and if so can you attach any relevant stack trace to this bug report? Does the uploaded file have any non-ANSI characters in the name? Does this occur with all files, or can some be uploaded successfully? I've been busy with other things lately so haven't had a lot of time for JAMWiki development, but it's a long weekend here in the US so hopefully I'll be able to investigate in the next couple of days.
        Pawel Sawicki
        added a comment -

        Hi Ryan,

        no, there aren't any error messages in the logs. It seams to be the expected behavior when no file could be uploaded. This occur with all files, regardless of the filename. Let me know if I can help with anything. I tried to build JamWiki myself, but there are some problems with the repositories (doesn't exist any more) of some dependencies.

        I hope you enjoyed the long weekend. Here in Germany we also have a long weekend.

        Best regards
        Pawel

        Show
        Pawel Sawicki
        added a comment - Hi Ryan, no, there aren't any error messages in the logs. It seams to be the expected behavior when no file could be uploaded. This occur with all files, regardless of the filename. Let me know if I can help with anything. I tried to build JamWiki myself, but there are some problems with the repositories (doesn't exist any more) of some dependencies. I hope you enjoyed the long weekend. Here in Germany we also have a long weekend. Best regards Pawel
        Ryan Holliday
        added a comment -

        Hi Pawel,

        I don't use Glassfish, but is it possible you have multiple versions of commons-fileupload in your classpath? Alternately, since you mentioned you are using 3.1.2, is it possible you are running into the same issue as https://community.jboss.org/thread/196311?_sscc=t (see http://java.net/jira/browse/GLASSFISH-18444 for the Glassfish issue report)?

        Alternately, if you'd like to build JAMWiki yourself the trunk and branches/1.2.x branch should now have the Maven problem you mentioned fixed - it looks like someone removed a version of exp4j from the Maven Central repository for some reason, which broke the JAMWiki build.

        Ryan

        Show
        Ryan Holliday
        added a comment - Hi Pawel, I don't use Glassfish, but is it possible you have multiple versions of commons-fileupload in your classpath? Alternately, since you mentioned you are using 3.1.2, is it possible you are running into the same issue as https://community.jboss.org/thread/196311?_sscc=t (see http://java.net/jira/browse/GLASSFISH-18444 for the Glassfish issue report)? Alternately, if you'd like to build JAMWiki yourself the trunk and branches/1.2.x branch should now have the Maven problem you mentioned fixed - it looks like someone removed a version of exp4j from the Maven Central repository for some reason, which broke the JAMWiki build. Ryan
        frank
        added a comment -

        Hola Guys,

        t looks like someone removed a version of exp4j from the Maven Central repository for some reason, which broke the JAMWiki build.
        I haven't notice removal of exp4j from maven central and if you do a search you can reach the artifact at: http://search.maven.org/#search%7Cga%7C1%7Cexp4j

        But maybe a <repository> element was pointing to the old nexus installation where exp4j was hosted, in which case id recommend removing the <repository> entry from the pom which points at "nexus.congrace.de"

        Hope that helped

        Frank

        Show
        frank
        added a comment - Hola Guys, t looks like someone removed a version of exp4j from the Maven Central repository for some reason, which broke the JAMWiki build. I haven't notice removal of exp4j from maven central and if you do a search you can reach the artifact at: http://search.maven.org/#search%7Cga%7C1%7Cexp4j But maybe a <repository> element was pointing to the old nexus installation where exp4j was hosted, in which case id recommend removing the <repository> entry from the pom which points at "nexus.congrace.de" Hope that helped Frank
        Ryan Holliday
        added a comment -

        Hi Frank - JAMWiki 1.2 was using exp4j 0.2.8, which no longer seems to be in Maven. I've updated the JAMWiki dependencies (trunk and the 1.2.x branch) to exp4j 0.2.9 to resolve most of the problems, although anyone building off of the 1.2 tag would still see a build failure.

        Show
        Ryan Holliday
        added a comment - Hi Frank - JAMWiki 1.2 was using exp4j 0.2.8, which no longer seems to be in Maven. I've updated the JAMWiki dependencies (trunk and the 1.2.x branch) to exp4j 0.2.9 to resolve most of the problems, although anyone building off of the 1.2 tag would still see a build failure.
        frank
        added a comment -

        Hey Ryan,
        Now i'm really confused, 0.2.8 should not have been available on central at all, there was only a 0.2.8 artifact in the sonatype staging repo for a couple of days. 0.2.9 was the first version the sonatype guys let me push to central:
        https://issues.sonatype.org/browse/OSSRH-2334

        could a reference to the staging repo in a pom.xml or settings.xml or even a local artifact have caused this behaviour?

        Show
        frank
        added a comment - Hey Ryan, Now i'm really confused, 0.2.8 should not have been available on central at all, there was only a 0.2.8 artifact in the sonatype staging repo for a couple of days. 0.2.9 was the first version the sonatype guys let me push to central: https://issues.sonatype.org/browse/OSSRH-2334 could a reference to the staging repo in a pom.xml or settings.xml or even a local artifact have caused this behaviour?
        Ryan Holliday
        added a comment -

        I've created a separate issue for the exp4j dependency in JAMWIKI-94 to avoid having two bug reports in a single issue.

        Show
        Ryan Holliday
        added a comment - I've created a separate issue for the exp4j dependency in JAMWIKI-94 to avoid having two bug reports in a single issue.
        Ryan Holliday
        added a comment - - edited

        Marking as won't fix since the problem appears to be a bug in Glassfish - link to a Glassfish patch provided in the bug comments. Note that another user reported the same problem on jamwiki.org, and applying the Glassfish patch was confirmed to resolve the problem.

        Show
        Ryan Holliday
        added a comment - - edited Marking as won't fix since the problem appears to be a bug in Glassfish - link to a Glassfish patch provided in the bug comments. Note that another user reported the same problem on jamwiki.org, and applying the Glassfish patch was confirmed to resolve the problem.
        Ryan Holliday
        made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]

          People

          • Assignee:
            Ryan Holliday
            Reporter:
            Pawel Sawicki
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: