JAMWiki
  1. JAMWiki
  2. JAMWIKI-109

Caused by: java.lang.ClassNotFoundException: org.jamwiki.db.H2DataHandler

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3
    • Fix Version/s: 1.3
    • Labels:
      None
    • Environment:

      OS - Windows 7
      DB - H2
      Tomcat 6.0.36

      Description

      Can not start jamwiki 1.3 with h2 db, and got error message
      Caused by: java.lang.ClassNotFoundException: org.jamwiki.db.H2DataHandler

      Please see the attachment

        Activity

        Ryan Holliday
        added a comment -

        It looks like H2 got missed in the migration code in AnsiDataHandler.LEGACY_DATA_HANDLER_MAP. I'll get a fix committed shortly - thanks for the report.

        Show
        Ryan Holliday
        added a comment - It looks like H2 got missed in the migration code in AnsiDataHandler.LEGACY_DATA_HANDLER_MAP. I'll get a fix committed shortly - thanks for the report.
        Ryan Holliday
        added a comment -

        Revision 4263 should fix the problem, and I'll get it included for 1.3-beta2. In the mean time, you can edit your jamwiki.properties file and change the "database-type" value to "org.jamwiki.db.H2QueryHandler". If you then restart everything should work as expected, but please let me know if there are issues. Thanks again for the bug report.

        Show
        Ryan Holliday
        added a comment - Revision 4263 should fix the problem, and I'll get it included for 1.3-beta2. In the mean time, you can edit your jamwiki.properties file and change the "database-type" value to "org.jamwiki.db.H2QueryHandler". If you then restart everything should work as expected, but please let me know if there are issues. Thanks again for the bug report.
        kcheng
        added a comment -

        tested, it's fixed in the 1.3-beta2

        Show
        kcheng
        added a comment - tested, it's fixed in the 1.3-beta2

          People

          • Assignee:
            Ryan Holliday
            Reporter:
            kcheng
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: